Karta HDTV USB DVB-T af9015 pod debianem

Dziś powiem jak zainstalować taką kartę – aby sprawdzić czy to aby na pewno taka wpisujemy
$ lsusb
i powinno wyświetlić coś podobnego:

Bus 001 Device 003: ID 15a4:9016 Afatech Technologies, Inc. AF9015 DVB-T USB2.0 stick

sprawdźmy co mówi log systemowy:
$ dmesg |grep af9015

jeśli wypisze że nie można zarejestrować urządzenia po prostu brak firmwaru:

dvb-usb-af9015.fw

znajdujemy go w sieci, jest on dużej wielkości – 15KB XD
wklejamy do folderu /lib/firmware/

w terminalu ładujemy z uprawnieniami administratora moduł
$ modprobe dvb-usb-af9015

i resetujemy system

sprawdzamy log czy system wykrył kartę
$ dmesg |grep af9015

powinno pokazać coś takiego:

[ 7.891521] dvb-usb: downloading firmware from file ‘dvb-usb-af9015.fw’
[ 8.099118] usbcore: registered new interface driver dvb_usb_af9015

no i instalujemy program do wyszukiwania kanałów
$apt-get install w-scan

i uruchamiamy skanowanie:
$ w_scan -c PL -ft -X

na koniec pojawi się log: dotyczy nas to:
TVP1 HD(EmiTel):706000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:102:104:1
TVP INFO Lublin(EmiTel):706000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:1402:1404:14
ESKA TV(EmiTel):706000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:302:303:27
TTV(EmiTel):706000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:402:404:28
POLO TV(EmiTel):706000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:502:503:29
ATM Rozrywka TV(EmiTel):706000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:602:603:30

tworzymy nowy plik tv.conf w folderze np wideo w folderze home i wklejamy zawartość programów

Plik otwieramy za pomocą vlc kaffeine lub metv.

P.S. Karta i moduł działają dopiero od jądra 2.6.28

Plank dock – minimalistycznie pod Debianem

Instalacja tegoż docka to nie proste “dpkg -i” jako że dla ubuntu też nie trzeba nic wielkiego robić to dla debiana trzeba się chwileczkę pobawić. Do rzeczy

$ apt-get install automake gnome-common intltool libgee-dev libtool libx11-dev pkg-config valac

może się uda że coś będziecie mieli w systemie XD no to dalej (związane z gtk)

$ apt-get install libglib2.0-dev libwnck-3-dev libbamf3-dev libgtk-3-dev

$ bzr branch lp:plank
$ cd plank/
$ ./autogen.sh –prefix=/usr
$ make

jeśli czegoś będzie brak trzeba to doinstalować

$ make install

no i ma działać :

$ plank

i buuuuuuja XD

Openbox – szybko łatwo i przyjemnie: prosty wm bez zbędnych rzeczy

Open box jest łatwym w obsłudze ale i mało posiadającym window managerem (wm). Jeśli ktoś nie wie o co chodzi to może nazwy takie jak gnome, kde, xfce dają coś do myślenia 🙂

Czym może poszczycić się Openbox?
-małe zużycie zasobów
-brak zintegrowanych programów – z tąd i tych potrzebnych jak i niepotrzebnych brak
-prosta konfiguracja – xml lub narzędzia graficzne
-prostota i pożądek – jeśli ktoś lubi

Nie jest to w zasadzie drugi “gnome” ponieważ ten to cały zbiór programów i wtyczek.

Instalacja w debianie:
$ apt-get install openbox

Jeśli ktoś nie chce się bawić w configach to może zrobić to graficznie:

Narzędzie do konfiguracji
$ apt-get install obconf

Narzędzie do konfiguracji menu
$ apt-get install obmenu

Openbox przywita nas czarną tapetką XD której oczywiście nie da się zmienić, ponieważ tej opcji openbox nie posiada. Kliknijmy zatem prawym klawiszem i pokaże nam się menu 🙂 dobre i to.

Tak na marginesie myślę że opiszę zamienniki aplikacji gnoma do openboxa by tego “chochlika” całego nie pobierać.

Adobe Air dla linuxa i Gnome3: brak gnome keyring lub kde wallet

Sprawa jest bardzo prosta – instalujemy w synapticu jeden z tych pakietów zależnie od środowiska, ale cóż to nadal mamy problem:

sprawdzamy czy mamy w terminalu:

$ locate libgnome-keyring.so

powinno wyjść coś takiego:

$ ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0

$ ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0

uruchamiamy instalator adobe air i działa 🙂 //dowiązania można później usunąć